Geeks With Blogs

News
 
 
My Visual Identity
 
www.flickr.com
This is a Flickr badge showing photos in a set called Personal Favorites. Make your own badge here.

 
maina donaldson a pragmatist's blog
SP1 for Commerce Server 2007 has obviously been built to install over an existing, fully configured environment with sites already deployed.  When we recently installed a brand-new staging and production environment, the following exception kept showing up in the event log:
 
The following resources are old. They will not function correctly 
until they are upgraded:
Product Catalog (7.2.0)

The number and type of resources in this message may vary depending on what you have configured.
This exception can be reproduced as follows (on a new machine):
  • Install CS stack
  • Install SP1
  • Install site pup (pupped on a different SP1 machine)
Running the upgrade wizard will exit without action and has no effect on the error message.

This error occurs because when the SP1 installer does not encounter a site to upgrade, it actually does only half its job and fails to upgrade portions of the MSCS_Admin database.  To resolve this issue run the following command to upgrade the admin database:

CSConfig.exe /r Feature.MS.CS.Admin
 
 
 
 
 
 
Posted on Wednesday, October 17, 2007 4:49 PM Commerce Server | Back to top


Comments on this post: Commerce Server 2007 SP1 'resources are old' Error

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Maina Donaldson | Powered by: GeeksWithBlogs.net