Geeks With Blogs

News
Disclaimer: The views expressed on this blog are my own and do not necessarily reflect the views of my employer.

Creative Commons License


Check out my about.me profile!

INETA Community Speakers Program

Follow enriquelima on Twitter
Locations of visitors to this page

Intentional Thinking Enrique Lima

This is long overdue.  But here it is.

In the previous two sections I have discussed on how I got a CMMI v4.2 to take on the same fields as v5 and therefore be able to communicate with MTM and Lab Manager.  And that was quite a success. Yet when I opened up Lab Management while it was fully aware of the VMs being there, it refused to let me enroll them into an environment.  It kept stating there was no suitable host to deploy the VM to, error TF259115.

This was an indication something was not matching the expected network configuration between TFS and Hyper-V/SCVMM.

So, here are a couple of things that took place:

  1. Verified the network segment specified for network isolation matched what was configured physically for either DHCP or manually assigned IP addressing for the guest VMs
  2. Made sure TFS was fully aware of the configuration settings for the network location name.  For that I issued:  tfsconfig lab /settings /networklocation:”<name of the network location configured in SCVMM”

On that last item, that was key to making sure Lab Management communicated with the VMs and for it to allow enrollment into the new Virtual Environment.

Posted on Tuesday, February 15, 2011 7:56 AM TFS , Application Lifecycle Management , Lab Management | Back to top


Comments on this post: Adventures in Lab Management Configuration: Part 3 of 3

comments powered by Disqus

Copyright © Enrique Lima | Powered by: GeeksWithBlogs.net