Geeks With Blogs

Mike H. - Another Geek In Need... WebLog

The Configure Server Farm Account Settings page is not displayed, and the SharePoint Central Administration site is not configured correctly, when you run SharePoint Portal Server 2003 Setup

 

 

November 16, 2005

 

 

PROBLEM

SharePoint Portal Server 2003 installs great – or does it? After a seemingly clean install, the SharePoint Central Administration page would not display.

 

There were no events in the System, Application, or Security Logs.

 

Under C:\Program Files\SharePoint Portal Server\Logs I found a SPS_xxxxx_SPSADM.LOG file with an entry that indicated that the service account ‘administrator’ would fail when it attempted to use it to start up the instance.

 

 

HISTORY

This setup was for a domain controller that was promoted, and SPS 03 would be running on this server.

 

The DBMS is SQL 2K w/SP3a running on a member server.

 

For SPS03 a service account was created; the service account was added to the DC’s Administrator’s local group, and the service account was added to SQL Server and given the roles Security Administrators and Database Creators.

 

 

RESOLUTION

During the installation, you are prompted for a user (service) account that will be used to execute SPS. During development or quick deployments to VPC’s (as was the case here) it is not uncommon to simply use the Administrator account for that server.

 

When the server executing SPS 03 is an AD DC (Active Directory domain controller) you MUST include the domain name (not the machine name) when providing the setup this name. For example, if I’m going to use the Administrator account, and I am running on a DC named development, then the actual entry would be development\administrator.

 

By entering only the admin. name, the application attempts to insert the machineName in there instead of the DC name – and the rest as they say, is history.

Hope this is helpful.

Posted on Wednesday, November 16, 2005 10:46 AM SharePoint Services , SharePoint Portal Server | Back to top


Comments on this post: The Configure Server Farm Account Settings page is not displayed, and the SharePoint Central Administration site is not configured correctly, when you run SharePoint Portal Server 2003 Setup

No comments posted yet.
Your comment:
 (will show your gravatar)


Copyright © Michael J. Hamilton, Sr. | Powered by: GeeksWithBlogs.net