Geeks With Blogs
Joaquin Jares Just another geek's blog July 2008 Entries
Product Keys and Setup – Custom Action
The question from my previous post was: how do I validate a Product Key from a Wix Setup? The answer has many components. First, you have to create a dialog for your product key in Wix. This dialog should have some sort of formatted input (say, a repetition of six 4-letter groups). It should also have some sort of validation. Next, you need to have a custom action that will validate the key. It’s very important for this custom action not to be obvious to crack. Wix is very easy to modify as is, if ......

Posted On Sunday, July 27, 2008 2:44 PM

Product Keys and Setup – Random Thoughts
I was commissioned recently on making a Product Key system for a shrink wrap piece of software. And my first thought was: there must be some sort of best practice or pattern language for this. I mean, many people sell shrink wrap software every day, and inventing the procedure each time is just to costly and error probe. Turns out, I was wrong. There is no pattern or best practice for product keys (at least none that I could find in the internet, forums or books). It makes sense, though, for several ......

Posted On Saturday, July 26, 2008 4:12 PM

Matching Braces with Regex
3 years ago, I wrote this post: http://regexlib.com/REDetai... It contained a .Net regular expression that would match the highest level of matching braces, something that is needed more often than not when parsing languages. It will also return null if no matching braces are found. Finally, as an added bonus, it will ignore braces that are escaped with a backslash. Soon after I posted it, someone commented on it being impossible, because Finite Automatas can’t count. I didn’t ......

Posted On Thursday, July 24, 2008 1:07 AM

Alive again
It has been a long time. I really didn't feel the need to blog back then. But now I have a few things I'd like to share, and some peers recommended me to blog, so here I am. First, let me tell you that the experiment with Asterisk and the Linksys router didn't end up well. I mean, it worked and it worked ok. The problem was that the router couldn't cope with the processing required for Asterisk to work. When Asterisk was active, my poor little router restarted every 15 minutes or so. I always suspected ......

Posted On Tuesday, July 22, 2008 3:59 PM

Copyright © Joaquin Jares | Powered by: GeeksWithBlogs.net